
Apple Crisp
8		  granny smith apples Peel, core, and slice.

½	 cup	 granulated sugar
¼	 tsp	 ground cloves
½	 tsp	 ground cinnamon
¼	 tsp	 ground nutmeg
2	 tsp	 lemon juice

Add to apples and mix. Pour into a buttered   
9 by 13 inch baking dish.

½	 cup	 granulated sugar
¾	 cup	 unbleached white flour
6	 tbsp	 butter
⅛	 tsp	 salt

Blend until crumbly.

¼	 cup	 chopped pecans Add to flour mixture and sprinkle over apples.

Preheat oven to 350ºF. Bake for 45 minutes or until the apples are tender and the crust is brown.

Recipe Design Wizard™
The Recipe Design Wizard Plug-In for Adobe InDesign and InCopy for Mac and Windows enables you to bring your recipes into the twenty 
first century with a layout that is attractive and significantly easier to use than traditional recipes. The Recipe Design Wizard Plug-In effortlessly 
accomodates changes to the list of ingredients and the associated instructions by automatically reflowing the recipe and resizing the adornments 
(curly braces) as changes are made to either the layout or the content.

Quick Start Guide
•	 Recipe Design Wizard is available from the Adobe Exchange: https://exchange.adobe.com/apps/cc/674/recipe-design-wizard. Recipe Design 

Wizard is compatible with Adobe InDesign CC 2025 (Version 20.x) and Adobe InCopy CC 2025 (Version 20.x) for Mac and Windows. 
Earlier versions of InDesign and InCopy are no longer supported. You can download and install the Recipe Design Wizard directly from within 
InDesign or InCopy. Go the Window > Extensions > Adobe Exchange to open the Adobe Exchange window

•	 Customize the Keyboard Shortcuts, as described on the next page. On Windows, this is required if you want to use control-tab.
•	 Drag one of the Recipe Snippets into your document each time you are ready to create a new recipe.
•	 If desired, copy the Recipe Templates to your Documents folder and Double Click one to open (you may be unable to open the originals). Select 

the Sample Recipe, Copy, and Paste each time you are ready to create a new recipe.
•	 Select the Text Tool, and select the text in the first table cell.
•	 To create a correctly typeset fraction (e.g. 1/2) at any time, type option-shift-F 1/2 option-shift-f (Mac) or SHIFT-ALT-F 1/2 shift-alt-f 

(Windows). To switch from one form (e.g. 1/2) to the other (e.g. 1/2), select the desired text, and type option-shift-f (Mac) or shift-alt-f 
(Windows).

•	 Enter the quantity (e.g. ½) for the first ingredient, press Option-Tab (Mac) or CONTROL-Tab (Windows) to move to the next field, enter the 
units (e.g. cup), press Option-Tab (Mac) or CONTROL-Tab (Windows) to move to the next field, and enter the ingredient. If there are no units 
(e.g. 8 apples), press Option-Tab (Mac) or CONTROL-Tab (Windows) twice to skip the units field and move directly from the quantity field to 
the ingredient field.

•	 If there are additional ingredients, press Return, and repeat the previous step for the next ingredient.
•	 Press Tab twice to move to the final table cell in the row, and enter the instructions. (You can use SHIFT-TAB to move back to the previous table 

cell.)
•	 If either the ingredients or the instructions require more than one line, the Recipe Design Wizard will automatically insert the curly braces of the 

appropriate height, and will automatically adjust the height as you edit the recipe.
•	 If there are additional ingredients and instructions, press Tab to add a row to the table, and repeat the preceeding steps.
•	 Use Save As... to save the resulting document.

Hints for Formatting Recipes
•	 One of the most common errors in measuring ingredients is to confuse teaspoons and tablespoons. To reduce confusion, we therefore 

recommend the use of the standard abbreviations tsp and TBSP. Readers have told us that the use of all caps or all small caps for TBSP emphasizes 
the difference between tsp and TBSP. To create small caps at any time, type option-shift-c tbsp option-shift-c (Mac) or SHIFT-ALT-c tbsp 
shift-alt-c (Windows). To switch from one form (e.g. tbsp) to the other (e.g. tbsp), select the desired text, and type option-shift-c (Mac) or 
shift-alt-c (Windows).

•	 We often provide background information about the recipe between the title and the table, and we often place cooking and serving instructions 
below the table, to produce a more balanced appearance.

https://exchange.adobe.com/apps/cc/674/recipe-design-wizard


Customizing the Keyboard Shortcuts
•	 It is strongly recommended that you install the Recipe Design Wizard.indk Keyboard Shortcuts into the InDesign Shortcut Sets folder in the 

Presets folder in InDesign and choose this as the Shortcut Set using the Edit > Keyboard Shortcuts... menu, or manually define the following 
Shortcuts using the Edit > Keyboard Shortcuts... menu. The Quick Start Guide and the Hints for Formatting Recipes on the previous page assume 
that these Shortcuts are installed. Note that option-tab on the Mac inserts the tab character in a table cell, so no shortcut definition for Insert 
Special Character: Other: Tab is required on the Mac.

Product Area Command Context Mac Shortcut Windows Shortcut
Panel Menus Character: OpenType: All Small Caps Default Opt+Shift+C Shift+Alt+C
Panel Menus Character: OpenType: Fractions Default Opt+Shift+F Shift+Alt+F
Type Menu Insert Special Character: Other: Tab Default Ctrl+Tab

Customizing the Recipe Template
•	 We strongly suggest that you choose or customize a suitable template or snippet before formatting a significant number of recipes, since there is 

no automatic mechanism to reformat multiple recipes for a new paper size after entering them. Note that copying and pasting text preserves the 
original Font Size, Leading, and Tabs, but not Column Widths or Insets.

•	 Since recipes make heavy use of fractions, we strongly suggest that you use an Open Type Pro font, which includes built in fractions. Adobe 
generously supplies three suitable Open Type Pro fonts with InDesign cs: Adobe Caslon Pro, Adobe Garamond Pro, and Adobe Jenson Pro. 
Many other Open Type Pro fonts are available for purchase.

•	 To check whether typeset fractions (e.g. 1/2) or small caps are available in a particular font, select any text in that font, then view the OpenType 
Menu of the Character Palette Menu. If the [Fractions] or [All Small Caps] menu items are in square brackets, it indicates that fractions or 
small caps are not available in the current font. For more information, refer to the InDesign User Guide.

•	 Recipe Templates and Snippets are supplied for three paper sizes, as detailed in the following table. You can use one of the supplied templates or 
snippets, or begin with one of these, and customize it to suit your requirements.
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File Name Recipe Template Standard Recipe Template Medium Recipe Template Small
Paper Size 8½ x 11 in (Letter Size) 6 x 9 in 5 x 8 in
Margins 0.75 in 0.5 in 0.5 in

Font Adobe Caslon Pro Adobe Caslon Pro Adobe Caslon Pro

Font Size 12 pt 10 pt 9 pt

Leading 14.4 pt 12 pt 10.8 pt

Fi
rst
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n

Width 248 pt 176 pt 140 pt

Left Indent 72 pt 60 pt 54 pt

First Line Left Indent -72 pt -60 pt -54 pt

First Tab 22 pt 18 pt 16 pt

Second Tab 72 pt 60 pt 54 pt

Top Inset 7 pt 5 pt 5 pt

Bottom Inset 7 pt 5 pt 5 pt

Left Inset 4.5 pt 4.5 pt 4.5 pt

Right Inset 9 pt 9 pt 9 pt

Se
co

nd
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n Width 7.5 pt 6 pt 6 pt
Top Inset 7 pt 5 pt 5 pt
Bottom Inset 7 pt 5 pt 5 pt
Left Inset 0 pt 0 pt 0 pt
Right Inset 0 pt 0 pt 0 pt

Th
ird

 C
olu

m
n Width 248 pt 176 pt 140 pt

Top Inset 7 pt 5 pt 5 pt
Bottom Inset 7 pt 5 pt 5 pt
Left Inset 9 pt 9 pt 9 pt
Right Inset 0 pt 0 pt 0 pt
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Frame Content Graphic Graphic Graphic
Frame Width 4 pt 4 pt 4 pt
Frame Height 4 pt 4 pt 4 pt
Stroke Weight 3 pt 3 pt 3 pt
Stroke Color White White White
Align Stroke Align Stroke to Inside Align Stroke to Inside Align Stroke to Inside
Stroke Cap Butt Cap Butt Cap Butt Cap
Stroke Join Mitre Join Mitre Join Mitre Join
Fill Color Recipe Design Wizard Swatch Recipe Design Wizard Swatch Recipe Design Wizard Swatch
Fill Tint 100 % 100 % 100 %

Ad
or

nm
en

t Orientation Left Left Left
Fixed Width Not Checked Not Checked Not Checked
Table Cell Checked Checked Checked
Entire Column Checked Checked Checked

•	 We provide one row in our templates; extra rows can be inserted anywhere in the table at any time using the Insert Rows... function in the Table 
Menu. Extra rows can easily be added to the end of the table by pressing the tab key with the insertion point in the last cell of the table. If the 
table spans multiple pages, Copy and Paste the first row of the table (which contains the adornment) into one of the rows on the subsequent 
page to ensure that the adornments (curly braces) appear on each page containing a portion of the table.

•	 The first cell in each row of the table contains the ingredients. Tabs are used to separate these cells into three fields. The placement of the tabs has 
been chosen to allow the first two fields of most or all ingredients to fit on a single line.

•	 Choose Vertical Justification: Align Center as a Cell Option for all cells in the first and third columns of the table.
•	 The center cell in the first row of the table contains an embedded Text Frame with a width of 3 pts and a height of 4.5 pts. Recipe Design 

Wizard... has been selected from the Kitchen Wisdom Publishing submenu of the Plug-Ins menu to attach an Adornment to the embedded Text 
Frame, with an Orientation of Left and the Table Cell and Entire Column attributes checked.

•	 The Adornment (curly brace) is drawn only if the height of the table cell (excluding the Top and Bottom Insets) is greater than or equal to 2.5 
times the width of the table cell (including the Left and Right Insets). Therefore, it may be necessary to adjust the width of the second column 
when adjusting the font size, to ensure that the Adornment becomes visible when a second line of text is added (and is hidden when only a 
single line of text is present).

•	 Use Save As... from the File menu and select Format: InDesign cs template to save a template rather than a document. Using InDesign cs2 or 
newer, an alternative is to drag the text frame containing the recipe template to the desktop, to create a Snippet.

 Plug-In Menu
•	 The Recipe Design Wizard Plug-In menu can be used to add an adornment to any Text or Graphic Frame. While the primary purpose of this 

Plug-In is for formatting recipes, other uses are left to the reader’s imagination.
•	 Four Orientations are available from the Plug-In menu: Top, Left, Bottom, or Right.
•	 Fixed Width forces a width of 7.5 points. If this option is not checked, the width and height of the Adornment are determined by the width and 

height of the Text or Graphic Frame. Note that the Adornment is drawn only if the height is greater than or equal to 2.5 times the width.
•	 The Table Cell option causes the Adornment to take on the dimensions of the table cell (if any) containing the Frame. Note that the Adornment 

is inset by the Top and Bottom Inset of the table cell, but not by the Left and Right Inset.

History of the Recipe Design Wizard
From the time he began cooking, Herb Weiner, the developer of the Recipe Design Wizard Plug-In, has been frustrated by the inconvenient format 
used for recipes in traditional cookbooks. 
Herb developed his unique new recipe format in 1981 as a student and self-appointed note taker for a group of friends and coworkers taking Mexican 
cooking classes in the evening. The format allowed Herb to quickly and accurately record the ingredients and instructions for preparing them as 
groups of students simultaneously prepared three or four different dishes under the direction of a wonderful chef whose only record of her recipes was 
in her head. Because both the ingredients and the instructions for preparing them were organized sequentially and grouped logically in the notes, the 
recipes were far easier to prepare, even in handwritten form, than recipes from traditional cookbooks.
Herb used primitive software to format the recipes for distribution to the other students. The collection of Recipes from these classes was ultimately 
published as Beyond Tacos: Mexican Cuisine Copyright © 1984 by Regina Akers and Herb Weiner (ISBN 0-937383-00-7), and was the first time that 
this format was used in a published cookbook.
In the twenty years since Beyond Tacos was published, Herb has sought a software solution for formatting recipes. The support for tables 
first introduced by Microsoft Word offered capabilites significantly beyond anything else available at the time. Herb developed a technique 
(https://www.wiskit.com/postscript/quicktips/recipes.pdf ) for formatting recipes by embedding PostScript directly into Microsoft Word table cells 
on the Mac, but this technique is no longer supported in the latest version of Microsoft Word, nor was it ever supported by any other page layout 
program.

http://www.wiskit.com/postscript/quicktips/recipes.pdf


In 2003, Herb began exploring the possibility of developing a Plug-In for Adobe InDesign, and realized that InDesign is a layout and design software 
package based upon a modern, object-oriented architecture. It’s great to finally have a publishing solution that provides a powerful development 
environment, allowing us to solve a 23 year old problem. We’re delighted that the release of the Recipe Design Wizard Plug-In for Adobe InDesign 
finally brings Recipe publishing into the 21st century, and produces content that exceeds our customers’ expectations.
Recipe Design Wizard Version 1.0 for the Mac was completed in February, 2004. Based upon inquiries from Windows users, Herb investigated the 
feasibility of supporting a Windows version, and was pleased to discover that Adobe’s InDesign architecture made this feasible. Recipe Design Wizard 
Version 1.0 for Windows was completed in June, 2004. The User Interface is identical to the Mac version, with the exception of a few Keyboard 
Shortcuts.
Herb is anxious to hear your success stories using the Recipe Design Wizard Plug-In. You can email Herb at herbw@wiskit.com.

Contents of the Recipe Design Wizard package
•	 The Recipe Design Wizard Plug-In. The same Plug-In works with either InDesign or InCopy, but each platform (Mac and Windows) and each 

version of InDesign and InCopy require a matching platform and version of the Plug-In.
•	 Recipe Design Wizard.indk Keyboard Shortcuts.
•	 These instructions in PDF Format.
•	 Three Recipe Templates and three Recipe Snippets.
•	 Apple Crisp Recipe in InDesign Format.
•	 The Recipe Design Wizard Brochure in PDF Format. This brochure contains an additional recipe.
The Adobe Extension Manager installs the first two items into the Adobe InDesign or InCopy Application folder, and installs the remaining items in 
the Recipe Design Wizard folder on the Desktop.

Frequently Asked Questions
•	 What if I open a recipe or a recipe template without the Recipe Design Wizard Plug-In? What if I make changes and save it?
	 If you open a recipe, recipe template, or recipe snippet without the Recipe Design Wizard Plug-In, InDesign will warn you, and ask you whether 

you want to open the document. If you proceed, the adornments (curly braces) will not display or print. If you save the document, some or all of 
the adornments may be reset. We strongly recommend that you install the Recipe Design Wizard Plug-In prior to making any changes or saving 
any document that was created using the Recipe Design Wizard Plug-In.

•	 Why is there a small blue Frame (rectangle) in the top row of the second column of the table?
	 The Adornment (curly braces) must be associated with a Page Item (a Text or Graphic Frame). Adobe does not currently provide a mechanism 

to associate an Adornment with a table cell. We therefore insert a Text Frame (the small rectangle) into the top table cell (of each page) in each 
column that requires an Adornment.

•	 Is it possible to change the color of the Adornment?
	 Yes. The Adornment inherits the color from the fill color of the small blue Frame (rectangle) in the top row of the second column of the table 

(see above question). Select that small blue Frame, and set the Fill Color to any desired value. This will change the color of all Adornments in 
that column.

•	 Is the Recipe Design Wizard available for Quark XPress?
	 No. Adobe makes their InDesign Software Development Kit available at no charge, and then offers reasonably priced developer programs for 

developers that require additional support. Quark, on the other hand, charges a license fee for the use of their Quark XTensions Developer 
Kit. We don’t know whether it’s possible to provide the function of the Recipe Design Wizard as a Quark XTension, and we don’t intend to pay 
Quark’s steep admission fee just to find out. 

•	 What about Trademarks?
	 Only a lawyer would ask that. Adobe, InDesign, and InCopy are trademarks of Adobe. Apple and Mac are trademarks of Apple. Quark, XPress, 

and XTension are trademarks of Quark. Microsoft, Windows, and Word are trademarks of Microsoft. And Recipe Design Wizard is a trademark 
of Kitchen Wisdom.

Kitchen Wisdom publishes cookbooks and gourmet software, and 
provides software consulting and custom software development 
services for the Mac and Unix. Kitchen Wisdom’s Internet address 
wiskit.com uses the first three letters of KITchen and the first three 
letters of WISdom.
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